Описание встроенного языка системы 1С Предприятие


CreateObject


Создает объект агрегатного типа данных системы 1С:Предприятие и возвращает ссылку на него.

Синтаксис:

CreateObject(<ИмяАгрегатногоТипа>)

Англоязычный синоним:

CreateObject

Параметры:

<ИмяАгрегатногоТипа>

Строковое выражение, значение которого со­держит имя агрегатного типа данных, объявлен­ного в конфигураторе.

Возвращаемое значение:

Ссылка на созданный объект агрегатного типа данных.

Описание:

Метод CreateObject создает объект агрегатного типа данных системы 1С:Предприятие и возвращает ссылку на него. Данная функция обычно ис­пользуется одновременно с неявным определением переменной и присвоением ей ссылки на объект агрегатного типа данных.

Пример:

Процедура Загрузить()

   Если ФС.Существуетфайл(Путь + "\NUL") = 0 Тогда

      Предупреждение("Путь информационной базы не найден!");

   Иначе

      V7 = СоздатьОбъект("V77.Application");

      Открыта = V7.Initialize(V7.RMTrade, "/d" + Путь +

                              " /M /N" + Пользователь, "");

      Если Открыта = 0 Тогда

         Предупреждение("Ошибка открытия информационной базы");

         Возврат;

      КонецЕсли;

      Импорт = V7.CreateObject("Справочник.Контрагенты");

      Импорт.ВыбратьЭлементы();

      Пока Импорт.ПолучитьЭлемент() = 1 Цикл

         Если Импорт.ЭтоГруппа() = 0 Тогда

            Сообщить(Импорт.Наименование);

         КонецЕсли;

      КонецЦикла;

   КонецЕсли;

КонецПроцедуры




Начало  Назад  Вперед



Книжный магазин